Dec
27

Hi Brian,

I have a router with two interfaces running both RIP and EIGRP as follows:

Interface  IP-Address      OK? Method Status  Prot
Serial0    172.16.5.5      YES manual up      up
Serial1    172.16.1.5      YES manual up      up

router rip
 network 172.16.0.0
!
router eigrp 2001
 network 172.16.0.0

S0 should be RIP only, and S1 should be EIGRP only. RIP should not listen to broadcasts on S1
and EIGRP should not listen to multicasts on S0. How do I do that?

Since EIGRP uses periodic hellos to establish adjacency, passive-interface is sufficient in this case. Since passive-interface in EIGRP suppresses the generation of hellos out an interface, adjacency cannot be established, and therefore there can be no exchange of routes.

An even easier method of choosing which specific interfaces are running EIGRP is to use a wildcard mask when you use the network statement. The ‘network’ statement in IGP does not actually mean what networks you are advertising, it means what interfaces you are running the protocol on. If you only want to run EIGRP on your Serial 1 interface with an address of 172.16.1.5, use the following syntax:

router eigrp 2001
 network 172.16.1.5 0.0.0.0

This means that only the interface 172.16.1.5 is running EIGRP. The opposite of this most specific syntax would be:

router eigrp 2001
 network 0.0.0.0 255.255.255.255

This means that all interfaces are running EIGRP.

With RIP, the case is different than EIGRP. Since RIP does not use periodic hellos like EIGRP, OSPF, or IS-IS, passive-interface simply means that you will not send any routing updates out an interface. This does not mean that you will not receive routing updates in that interface. To prevent learning routes in an interface using RIP, you could use a distribute-list that denies everything (which would also work for EIGRP), or use an access-list that denies RIP altogether. Take the following examples:

access-list 1 deny any
!
router rip
 network 172.16.0.0
 distribute-list 1 in serial 1

or

access-list 100 deny udp any eq rip any eq rip
access-list 100 permit ip any any
!
interface serial 1
 ip access-group 100 in

Both would accomplish the same goal.

About Brian McGahan, CCIE #8593, CCDE #2013::13:

Brian McGahan was one of the youngest engineers in the world to obtain the CCIE, having achieved his first CCIE in Routing & Switching at the age of 20 in 2002. Brian has been teaching and developing CCIE training courses for over 10 years, and has assisted thousands of engineers in obtaining their CCIE certification. When not teaching or developing new products Brian consults with large ISPs and enterprise customers in the midwest region of the United States.

Find all posts by Brian McGahan, CCIE #8593, CCDE #2013::13 | Visit Website


You can leave a response, or trackback from your own site.

2 Responses to “How do I control which interfaces run EIGRP vs. RIP?”

 
  1. Random T. says:

    After reading through this article, I just feel that I really need more information on the topic. Can you suggest some resources please?

  2. [...] to a question that I have been wondering about for many years. Here is the scenario. We are running EIGRP, and have a neighbor, but no console access to that neighbor. We get the message on our local [...]

 

Leave a Reply

Categories

CCIE Bloggers