Dec
29

OSPF point-to-multipoint non-broadcast was designed to allow for the assignment of the cost on a per neighbor basis as opposed to using the interface’s cost. This
is useful on a multipoint Frame Relay interface where there are two neighbors advertising the same route but the CIRs for the DLCIs to reach each neighbor is different or these two neighbors that are advertising the same route have different port speeds to the Frame Relay network. Remember that the cost is based on your “incoming” interface’s bandwidth and not the bandwidth of the neighbor’s interface that connects to you.

As an example say we have two remote routers over Frame Relay and the remote routers are both connected to and advertising the same Ethernet segment. Our router is connected to these two routers via Frame Relay. One of the remote routers has a T1 Frame Relay connection and the other has a 64k Frame Relay connection. Since our cost to the Ethernet segment advertised by these two routers will be calculated based on the cost of the Ethernet segment plus the cost of our incoming interface, both routes appear to be equal cost. Obviously this is not what we would want. We would want to prefer the route from the router with the T1 connection over the 64k connection.

Here is an example with two remote routers advertising the same network (loopback interfaces):

Rack2R4#show ip ospf interface s0/0 | include Cost
  Process ID 1, Router ID 150.1.4.4, Network Type POINT_TO_MULTIPOINT, Cost: 64

Rack1R4#sho run int s0/0
interface Serial0/0
 ip address 154.1.0.4 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 frame-relay map ip 154.1.0.3 403 broadcast
 frame-relay map ip 154.1.0.5 405 broadcast
 no frame-relay inverse-arp
end

Rack2R4#sho ip route 150.1.0.0 255.255.255.0
Routing entry for 150.1.0.0/24
  Known via "ospf 1", distance 110, metric 65, type intra area
  Last update from 154.1.0.3 on Serial0/0, 00:00:30 ago
  Routing Descriptor Blocks:
  * 154.1.0.3, from 150.1.3.3, 00:00:30 ago, via Serial0/0
      Route metric is 65, traffic share count is 1
    154.1.0.5, from 150.1.5.5, 00:00:30 ago, via Serial0/0
      Route metric is 65, traffic share count is 1

As you can see both 154.1.0.3 (router-ID 150.1.3.3) and 154.1.0.5 (router-ID 150.1.5.5) are advertising the 150.1.0.0/24 network with an OSPF cost of 1 (total cost minus our interface’s cost, 65-64=1). If both of these routers have the same port speed to the Frame Relay network then this is what we would want to see, two equal cost paths. But if they have different port speeds, then we would want to prefer the route from the router with the higher port speed, theoretically. The problem is that OSPF does not take into account the cost of the remote router’s interface to us. We only take into account the cost of the loopback and our interface’s cost to reach the remote neighbor.

To prefer the route from the router with the higher port speed, we are going to use OSPF point-to-multipoint non-broadcast to specify the cost on a per neighbor basis. In this example we are going to add a cost of 25 to the routes from 154.1.0.5 and 50 to the routes from 154.1.0.3.

Rack1R4#sho run | be router ospf
router ospf 1
 network 154.1.0.0 0.0.255.255 area 0
 neighbor 154.1.0.5 cost 25
 neighbor 154.1.0.3 cost 50

Rack1R4#sho run int s0/0
interface Serial0/0
 ip address 154.1.0.4 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint non-broadcast
 frame-relay map ip 154.1.0.3 403 broadcast
 frame-relay map ip 154.1.0.5 405 broadcast
 no frame-relay inverse-arp
end

Rack1R4#sho ip route 150.1.0.0 255.255.255.0
Routing entry for 150.1.0.0/24
  Known via "ospf 1", distance 110, metric 26, type intra area
  Last update from 154.1.0.5 on Serial0/0, 00:06:13 ago
  Routing Descriptor Blocks:
  * 154.1.0.5, from 150.1.5.5, 00:06:13 ago, via Serial0/0
      Route metric is 26, traffic share count is 1
      ^^^^^^^^^^^^^^^^^^^

Now we can see that we prefer the route from 154.1.0.5 (router-ID 150.1.5.5).

About Brian Dennis, CCIE #2210:

Brian Dennis has been in the networking industry for more than 22 years, with a focus on Cisco networking for the past 16 years. Brian achieved his first CCIE in Routing & Switching in 1996, and is currently the only ten year CCIE that holds five CCIE certifications. Prior to working with INE, Brian taught and developed CCIE preparation courses for various well known training organizations. Brian not only brings his years of teaching experience to the classroom, but also years of real world enterprise and service provider experience.

Find all posts by Brian Dennis, CCIE #2210 | Visit Website


You can leave a response, or trackback from your own site.

16 Responses to “Understanding the OSPF Point-to-Multipoint Non-broadcast Network Type”

 
  1. daghighi says:

    Very interesting to read this kind of explanation.
    Thanks,
    Navid

  2. limame says:

    It is one of better pages than I read on this subject.
    Thank you for you mister.

  3. diriger says:

    Thank you very much, Brian! But how did you know that? I think it is not easy to guess what is the goal of point-to-point non broadcast design by oneself.

  4. Arunkumar says:

    Thanks for that info i couldnt find a proper explanation on the topic anywhere but this was to the point and just what i was looking for .

  5. Thank you for usefull info.

  6. Hakim says:

    Thanks for the article. Once question, do we still have to use “broadcast” in frame relay mapping in point-to-multipoint non-broadcast network mode?

  7. AJN says:

    ===> **** Remember that the cost is based on your “incoming” interface’s bandwidth and not the bandwidth of the neighbor’s interface that connects to you **** <===

    That's worth the emphasis.

    Thank you Brian.

  8. suryakant says:

    Hello Brian -
    I have qustion regarding to point to multipoint non-broadcast.

    As you expalined this type was designed to allow for the assignment of the cost on a per neighbor basis, can i achive the same result with point to multipoint. I mean I can assign cost to neighbor under ospf process and i will use network type as point to multipoint.

    thanks
    surya

  9. Paul Vijay says:

    Thanks a lot for the Explaination.. That was awesome..Until now I never had a idea why P2M NB used for, now you made it all clear

  10. Deji says:

    Nice one! Concept demystified.

    However, I think a simple network diagram illustrating this could have made more points in the explanation.

  11. Stephen says:

    Hi Brian.

    I’ve labbed this up in a point-to-multipoint network, and the cost can be assigned on a per neighbor basis too. It’s talked about at the start of this post too (http://www.cisco.com/en/US/docs/ios/11_3/feature/guide/ospfpmp.html#wp7054)

    In the lab below I demonstrate this.

    interface Serial1/0
    ip address 10.0.0.3 255.255.255.0
    encapsulation frame-relay
    ip ospf network point-to-multipoint
    frame-relay map ip 10.0.0.1 301 broadcast
    frame-relay map ip 10.0.0.2 302 broadcast
    no frame-relay inverse-arp
    end
    !
    router ospf 1
    router-id 3.3.3.3
    log-adjacency-changes
    network 10.0.0.0 0.0.0.255 area 0
    neighbor 10.0.0.1 cost 5
    neighbor 10.0.0.2 cost 4
    !
    R3#sh ip route 12.12.12.0
    Routing entry for 12.12.12.0/24
    Known via “ospf 1″, distance 110, metric 5, type intra area
    Last update from 10.0.0.2 on Serial1/0, 00:01:39 ago
    Routing Descriptor Blocks:
    * 10.0.0.2, from 2.2.2.2, 00:01:39 ago, via Serial1/0
    Route metric is 5, traffic share count is 1
    !
    R3(config)#router ospf 1
    R3(config-router)#neighbor 10.0.0.2 cost 10
    R3(config-router)#end
    !
    R3#sh ip route 12.12.12.0
    Routing entry for 12.12.12.0/24
    Known via “ospf 1″, distance 110, metric 6, type intra area
    Last update from 10.0.0.1 on Serial1/0, 00:00:31 ago
    Routing Descriptor Blocks:
    * 10.0.0.1, from 2.2.2.2, 00:00:31 ago, via Serial1/0
    Route metric is 6, traffic share count is 1

  12. Deva says:

    What if we change the ospf cost on Interface of routers connecting to ethernet segment it still works right ?

 

Leave a Reply

Categories

CCIE Bloggers