Jan
08

By adjusting the hello/dead timers you can make non-compatible OSPF network types appear as neighbors via the “show ip ospf neighbor” but they won’t become “adjacent” with each other.  OSPF network types that use a DR (broadcast and non-broadcast) can neighbor with each other and function properly.  Likewise OSPF network types (point-to-point and point-to-multipoint) that do not use a DR can neighbor with each other and function properly.  But if you mix DR types with non-DR types they will not function properly (i.e. not fully adjacent).  You should see in the OSPF database “Adv Router is not-reachable” messages when you’ve mixed DR and non-DR types.

Here is what will work:

Broadcast to Broadcast
Non-Broadcast to Non-Broadcast
Point-to-Point to Point-to-Point
Point-to-Multipoint to Point-to-Multipoint
Broadcast to Non-Broadcast (adjust hello/dead timers)
Point-to-Point to Point-to-Multipoint (adjust hello/dead timers)

About Brian Dennis, CCIE #2210:

Brian Dennis has been in the networking industry for more than 22 years, with a focus on Cisco networking for the past 16 years. Brian achieved his first CCIE in Routing & Switching in 1996, and is currently the only ten year CCIE that holds five CCIE certifications. Prior to working with INE, Brian taught and developed CCIE preparation courses for various well known training organizations. Brian not only brings his years of teaching experience to the classroom, but also years of real world enterprise and service provider experience.

Find all posts by Brian Dennis, CCIE #2210 | Visit Website


You can leave a response, or trackback from your own site.

9 Responses to “Understanding OSPF Network Types”

 
  1. segun daniel says:

    thax for this informatiom men.you are the only guy who ve been able to come out pure and tell us the combination and how it works.

    thax again more greese to yuor elbow

  2. Rajneesh says:

    thanks for the information. No body given this deeply idea.

  3. Stephan says:

    Dear sirs,

    thank you so much for your explanation. I’ve tried to do something after reading your article here, and what I did is the following:

    3 routers.

    (R3) —- (R1) —- (R5)

    They all are running over frame relay interfaces. RouterB is configured with the following configuration:

    interface Serial1/0
    ip address 192.168.0.1 255.255.255.0
    encapsulation frame-relay
    ip ospf network point-to-multipoint
    serial restart-delay 0
    frame-relay map ip 192.168.0.3 103 broadcast
    frame-relay map ip 192.168.0.4 104 broadcast
    no frame-relay inverse-arp
    end

    RouterA is configuring like this:

    interface Serial1/0
    ip address 192.168.0.3 255.255.255.0
    encapsulation frame-relay
    ip ospf network point-to-point
    ip ospf hello-interval 30
    serial restart-delay 0
    frame-relay map ip 192.168.0.1 301 broadcast
    no frame-relay inverse-arp
    end

    And the most interesting part – RouterC:

    interface Serial1/0.1 point-to-point
    ip address 192.168.0.5 255.255.255.0
    ip ospf network broadcast
    ip ospf hello-interval 30
    ip ospf priority 200
    frame-relay interface-dlci 501
    end

    RouterA and RouterB has formed successful adjacency and update their links as well.

    Now, RouterB has formed adjacency with router C (even if they are in different network types) but no routes are installed into the database.

    RouterC considers itself as DR (because it’s configured with prio 200 and it’s running broadcast network mode) while RouterB is just a p2p neighbor with FULL/- ospf neighbor state.

    RouterC database shows the following:

    Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum
    192.168.0.5 192.168.0.5 737 0×80000001 0x008CF7

    R5#show ip ospf database network

    OSPF Router with ID (192.168.0.5) (Process ID 1)

    Net Link States (Area 0)

    Routing Bit Set on this LSA
    LS age: 748
    Options: (No TOS-capability, DC)
    LS Type: Network Links
    Link State ID: 192.168.0.5 (address of Designated Router)
    Advertising Router: 192.168.0.5
    LS Seq Number: 80000001
    Checksum: 0x8CF7
    Length: 32
    Network Mask: /24
    Attached Router: 192.168.0.5
    Attached Router: 192.168.0.1

    So the link in LSA2 confirms that router is running in DR mode on that link, so I’m thinking it’s normal to accept routes from R1 and at least install them in the routing table. But not:

    R5#show ip ospf database router 192.168.0.1

    OSPF Router with ID (192.168.0.5) (Process ID 1)

    Router Link States (Area 0)

    Adv Router is not-reachable <——————————– where is not reachable ? The ping confirms that there is a reachability between them

    LS age: 1069
    Options: (No TOS-capability, DC)
    LS Type: Router Links
    Link State ID: 192.168.0.1
    Advertising Router: 192.168.0.1
    LS Seq Number: 80000028
    Checksum: 0x1D28
    Length: 84
    Number of Links: 5

    [CUT]

    Can you, please help me to understand what is actually happen?

    One more thing. What does “Routing Bit Set on this LSA ” actually means, and where we should see it?

    Thank you so much in advance!

  4. Iqbal says:

    Brian!

    Spot on explanation! U rock! Thanks!

  5. siddharth says:

    to form neighbors hello timer and dead timer must match
    in the above case hello and dead timers match even tho network types are different so neighbors are formed.
    for routes to exist network type should be same.

    i hope this helped

  6. siddharth says:

    i forgot to add
    hello is 30s
    and dead is 40s for all routers so neighbors are formed

  7. Vivek says:

    Hi Brian,

    I have a question about OSPF. How a router will identify that the connected neighbor interface is a broadcast/ point-to-point network?

    Ofcourse we will identify this from show ip ospf interface output. But I have not noticed any such category in OSPF packets which will say that the remote interface will be in broadcast/ P2P. If there is no such criteria, then why DR and BDR election is not happening in point to point setup?

    All Hello timers are manipulated… So this can’t be a factor for this.

    Please help me in this regard. If possible.

    Thanks

    Vivek

  8. Vivek says:

    Hi Brian,

    I didn’t get my answer. I was not asking link-type.. Please correct me if I am wrong.

    R1[fa0/0]——————————–[fa0/0]R2

    I have enabled ospf in both the interface as per above diagram. In this Scenario DR/ BDR election will happen as the segment is ethernet media. As per my knowledge LSA propogation will happen only after the master/ slave relationship.

    But the DR/ BDR election should happen in 2-way state. So my question is how the neighbor will identify that this is broadcast media/ serial (TDM) link?

    I have done a quick test on this also. I stopped ospf neighborship in exstart state with mismath of MTU size. WIthin that period I have not noticed any LSA in the ethereal capture.

    Thanks for your quick answer.

    Vivek

 

Leave a Reply

Categories

CCIE Bloggers