Jan
20

Below are a couple example configurations for PPPoE. Note that you can run into MTU issues when trying to use OSPF over PPPoE. This can easily be resolved by using the “ip ospf mtu-ignore” command as the dialer interface’s MTU is 1492 while the virtual-template’s (virtual-access) MTU is 1500.

*** Client ***
interface Ethernet0/0
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface Dialer1
 ip address 142.1.35.5 255.255.255.0
 encapsulation ppp
 dialer-pool 1
 dialer persistent

*** Server ***

vpdn enable
!
vpdn-group CISCO
 accept-dialin
 protocol pppoe
 virtual-template 1
!
interface Ethernet0/0
 pppoe enable
!
interface Virtual-Template1
 ip address 142.1.35.3 255.255.255.0

The next example is using DHCP to assign the client their IP address:

*** Client ***

interface Ethernet0/1
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface Dialer1
 ip address dhcp
 encapsulation ppp
 dialer pool 1
 dialer persistent

*** Server ***

ip dhcp excluded-address 191.1.45.1 190.12.45.3
!
ip dhcp pool MYPOOL
 network 191.1.45.0 255.255.255.0
!
vpdn enable
!
vpdn-group CISCO
 accept-dialin
 protocol pppoe
 virtual-template 1
!
interface Ethernet0/0
 pppoe enable
!
interface Virtual-Template1
 ip address 191.1.45.5 255.255.255.0
 peer default ip address dhcp-pool MYPOOL
About Brian Dennis, CCIE #2210:

Brian Dennis has been in the networking industry for more than 22 years, with a focus on Cisco networking for the past 16 years. Brian achieved his first CCIE in Routing & Switching in 1996, and is currently the only ten year CCIE that holds five CCIE certifications. Prior to working with INE, Brian taught and developed CCIE preparation courses for various well known training organizations. Brian not only brings his years of teaching experience to the classroom, but also years of real world enterprise and service provider experience.

Find all posts by Brian Dennis, CCIE #2210 | Visit Website


You can leave a response, or trackback from your own site.

8 Responses to “Example Configurations for PPP over Ethernet (PPPoE)”

 
  1. Saptanshu says:

    Hi Brian,

    But in that case server will not be able to ping its own interface. To ping own interface of server

    *** Server ***

    ip dhcp excluded-address 191.1.45.1 190.12.45.3
    !
    ip dhcp pool MYPOOL
    network 191.1.45.0 255.255.255.0
    !
    vpdn enable
    !
    vpdn-group CISCO
    accept-dialin
    protocol pppoe
    virtual-template 1
    !
    interface Ethernet0/0
    ip address 191.1.45.5 255.255.255.0
    pppoe enable
    !
    interface Virtual-Template1
    ip unnumbered e0/0
    peer default ip address dhcp-pool MYPOOL

    Please correct if i am wrong.
    In Lab do we need to ping own interface of server in VPDN’s.

    Regards
    Saptanshu

  2. Vlad says:

    Thank you.

    Follow up questions:
    Which interface you apply QoS, NBAR-prot-discovery, NetFlow-export, etc?
    Dialer interface would not accept any MQC policy.
    Any way to get a “virtual-template” for a ppoe client?
    “match-protocol” with NBAR does not work (no matches) when the policy is assigned to ethernet interface.

    interface Ethernet1
    bandwidth 128
    no ip address
    pppoe enable group global
    pppoe-client dial-pool-number 1
    service-policy output QOS-OUT
    !
    interface Dialer1
    mtu 1492
    bandwidth 128000
    ip address negotiated
    ip accounting output-packets
    ip accounting precedence output
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat outside
    encapsulation ppp
    dialer pool 1
    ppp pap sent-username [....] password [...]

    policy-map QOS-OUT
    class DNS
    priority 8
    class class-default
    fair-queue
    random-detect
    random-detect precedence 1 10 20 2
    random-detect precedence 5 100 200 11
    random-detect precedence 7 100 200 20
    shape average 100000

  3. [...] PPP supports authentication [PAP, CHAP, MS-CHAP], multilinking & routing, know virtual templates, PPPoE [dialin & client] – Watch IOS!!!!! e.g. http://blog.ine.com/2008/01/20/example-configurations-for-ppp-over-ethernet-pppoe/ [...]

  4. stychu says:

    hi Brian ,
    thank you for that post and please can you send the best reference cco docs for the pppoe for r&s version 4.0 . Thank you for your help .
    stychu

  5. Roland says:

    What if the dhcp pool is on a remote router?
    I can’t make it work. DHCP pool on remote router in correct, ip dhcp-server set on PPPoE server side.
    The DHCP server receives DHCP requests from PPPoE server but the answer never arrives to PPPoE client.
    How do I fix it?
    Thanks in advance.

  6. Arul says:

    Hi Brian Dennis,
    how to Emulate dual-stack PPPoE client using dialer ?

    I currently have below configuration. But i’m getting only ipv4 address allocated, not the ipv6 address with the help of dhcp.

    Server side configuration is in place. when i use ixN2x Tgen sessions comes up in dual-stack. want to know how to use 7200 router to emulate Dual stack PPPoE Session using dialers.

    please let me know.

    7200-2#sh run int gi0/2.102
    Building configuration…

    Current configuration : 127 bytes
    !
    interface GigabitEthernet0/2.102
    encapsulation dot1Q 102
    pppoe enable group global
    pppoe-client dial-pool-number 102
    end

    7200-2#sh run int dialer 102
    Building configuration…

    Current configuration : 293 bytes
    !
    interface Dialer102
    ip address negotiated
    encapsulation ppp
    dialer pool 102
    dialer idle-timeout 0
    dialer persistent
    ipv6 address dhcp rapid-commit
    ppp authentication pap callin
    ppp pap sent-username DaffyDuck_P26@Tasmainia1 password 0 LooneyTunes_P26
    ppp ipcp route default
    !
    end

    7200-2#

    Thanks,
    Arul

 

Leave a Reply

Categories

CCIE Bloggers