Nov
12

A common question we hear in our classes is “should I configure XYZ on device(s) PDQ?”

My answer is always the same…I do not bother configuring anything unless I am explicitly or implicitly asked to do so in the lab exam. But what does that mean? Let me further explain here.

An example of a task that explicitly asks us to configure something would be as follows:

2.3 Configure an 802.1Q trunk between SW1 and SW4 using Fa0/12.

Solution:
SW1
interface fa0/12
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown

SW4
interface fa0/12
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown

It gets trickier with an implicitly stated requirement. Here is an example:

2.5 Create a Cisco proprietary trunk link between SW1 and SW4 using Fa0/12. Ensure these devices do not send or respond to frames attempting to establish the trunk dynamically.

Solution:
SW1
interface fa0/12
switchport trunk encapsulation isl
switchport mode trunk
switchport nonegotiate
no shutdown

SW4
interface fa0/12
switchport trunk encapsulation isl
switchport mode trunk
switchport nonegotiate
no shutdown

Another form of an implicit task requirement involves the relationship between tasks. This can be the most difficult task configuration to catch! For example, you might have the requirement to configure RIP version 2 between two routers. Later in the lab exam, you are asked to configure an Access Control List (ACL) on one of the interfaces between the routers. This access list task does not explicitly state that RIP version 2 should be permitted, but we must understand it is implicitly stated since the earlier task requires that RIP flow between the devices.

I hope this post helps with your lab strategies!


You can leave a response, or trackback from your own site.

5 Responses to “The Lab Made Me Do It – Implicit versus Explicit”

 
  1. dh says:

    Excellent advice. Can we get a part II?

  2. ljankok says:

    Great Post,

    I think that the implicit task requirements are indeed the most difficult to catch. Last I had one where I had to make an ospf area where upon reading the requirements the choice was between a stub or a nssa. Looking further down the road it had to be a nssa for there was redistribution to be done from the area. Looking at the requirements I also had to use the no-distribution keyword for otherwise there would be redistribution done to the area.
    I find this another level of doing tasks.. good is not anymore that you got it working.. good is that you have it working when still adhering to all the requirements from all other tasks.

  3. Pete says:

    I think the only solution to these kind of questions is getting the biggest darn piece of paper you can get your hands on and drawing a diagram so big that you can note just about everything you do on an interface or device

  4. kaushal says:

    Really nice thread.

    Lets try to put some more such points. I will start posting in a month I believe.

    I am still halfway of my preparation.

 

Leave a Reply

Categories

CCIE Bloggers