Aug
23

I want to thank Rodney for this blog post idea. Rodney, like several others, did struggle a bit with some of the longer, scenario-based questions in the CCIE Written Exam. In fact, while these questions might not be too difficult, one tends to discover that time becomes a major factor in the written exam as a result of these question types.

In this blog post series, we will dissect some sample exam questions, and cover in detail how we might solve the query as quickly and efficiently as possible. Here is the first sample question:

Question 1 of 105

Examine the topology and partial router outputs shown in the Exhibits. How will the prefix of Loopback 0 on R1 appear on R6?

a) The prefix will be part of the External EIGRP learned route information

b) The prefix will be part of the Internal EIGRP learned route information

c) The prefix will be part of the eBGP learned route information

d) The prefix will be part of the iBGP learned route information

e) The prefix will not appear on R6

Exhibit 1

CCIE Written

Exhibit 2

hostname R1
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.60.60.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 200
 network 10.0.0.0
 no auto-summary
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 neighbor 10.10.10.2 remote-as 100
 neighbor 10.60.60.6 remote-as 200
 no auto-summary
!

Exhibit 3

hostname R2
!
interface FastEthernet0/0
 ip address 10.10.10.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.20.20.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 200
 network 10.0.0.0
 no auto-summary
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.10.1 remote-as 100
 no auto-summary
!

Exhibit 4

hostname R6
!
interface FastEthernet0/0
 ip address 10.50.50.6 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.60.60.6 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 200
 redistribute bgp 200 metric 1000 0 255 1 1500
 network 10.0.0.0
 no auto-summary
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.50.50.5 remote-as 200
 neighbor 10.60.60.1 remote-as 100
 no auto-summary

The first step in solving something like this is very simply not allowing yourself to become overwhelmed. Remember to break down a problem into smaller parts. Here is my mental logic as I begin…

“If R6 truly learns of the prefix from EIGRP, External EIGRP, eBGP, and iBGP, which protocol will win the Administrative Distance battle? eBGP certainly will win with its incredible AD of 20. So all I need to do is check the exhibits to ensure that R6 will learn of this prefix via eBGP!”

After going through this logic, I check the output of R1. Yes, it appears the prefix is properly advertised via BGP, and it should be sent to R6 via eBGP. I learn this from the neighbor statement, and the network statement on R1. I then check for the proper BGP config on R6. This just consists of the correct neighbor statement. Finally, I give the R2 config a quick peek, and immediately discover that it is not really relevant to answer this question.

I choose option “c) The prefix will be part of the eBGP learned route information” and move on to the next question with confidence. Notice that this may have looked really tough and complex, but it was actually quite simple and we only took about 2 minutes to answer it.

For more products to help with this Tier 1 knowledge, check out:

I sure hope you enjoyed the first post in this series, and as always, enjoy your studies immensely!


You can leave a response, or trackback from your own site.

9 Responses to “CCIE R/S Written Sample Question – Part 1”

 
  1. Bob says:

    So the “hard” part of this question was to doublecheck that there is no misconfiguration?

    Barring a “gotcha” this looks like a really simple question to me. Although I found that the hard questions on the written test are the ones where you go “what the hell kind of idiot question is this?”.

    Like (but not exactly, since I don’t want to give the questions away):

    * What is the port number of LDAP? (uh…. I’d google that, or check /etc/services)

    * Are OSPF areas stubby or totally stubby? (they can be either, you idiot test)

    * Are MPLS or L2TPv3 PW best? (best when doing what?)

  2. Yandy Ramirez says:

    This is a cool sample question. Cause although simple, as you mentioned allot of people get overwhelmed by the amount of information. Or they simply expect some trickery some where.

    Really well done on this one… ;)

    Thanks

  3. jkdrouter says:

    Nice idea for the blog and a nice review for those who already passed written.

    From my experience on the written, these types of questions are actually the easiest and are answered quickly, mostly due to the fact that there IS alot of information presented, but cisco does understand you are not going to spend 10 minutes solving the problem, thus the most obvious approach to the problem is usually the best and correct.

    Having said that, you could add more OSPF/LSA-type-propagation type of problems! I remember those being hardest (i still managed 100% on RS section :>)

  4. Nice post. May I make a suggestion? When you post the OSPF loop back question (and Im sure you will), please include the routing table output. :o )

  5. andy jordan says:

    actually in this example , all you need to look at is the R1 config , and you will notice that R1 is not advertising the loopback via eigrp at all !

  6. David says:

    Great idea…love the part where you explain your process of thinking.

  7. sarlulu says:

    Understandable and brief explanation. keep it up..

  8. Marlon says:

    Hi, if you could come up with one or two set of difficult questions similar to this on the “CCIE Written Bootcamp Online” and if you could explain the rationale and approach if possible, that would be simply outstanding, I would definitely buy those questions. I hope you could do that soon though because my exam is on 09/04/09 :-)

 

Leave a Reply

Categories

CCIE Bloggers