Dec
07

Hi Everyone,

In response to the recent feedback from our students, we have implemented several changes to our IEWB-RS VOL1 and VOL2 workbooks. Specifically, ten out of twenty VOL2 labs have been modified to match the lab “style” used in the new CCIE R&S configuration section. The modification include the following:

  • Merging together some Layer2/IGP/BGP tasks into larger sections with higher score, e.g. 4 or 5 points. This is what Cisco seems to be doing to the sections known as “core” previously. Larger sections are harder to complete, since the chances of mistake are now higher. Beside, the “core” topics now have less points than it was previously.
  • Adding more “non-core” topics, such as IP Services, IOS Features, Security, QoS, OER, IPv6 and so on. You will see the updated labs to shift more points towards the non-core sections.

The modified VOL2 labs are all labs with odd-numbers (1,3,5…). The even numbered labs retain the “older” style (small modular tasks) to give you a variety of different approaches. You may take the labs in normal sequence (1,2,3…) or if you have limited time run through the updated labs only. I would recommend taking all the labs for better topic coverage. You may look at the free sample “new-style” lab by following this link: IEWB-RS VOL2 Sample Lab The first three updated labs will be posted today, with the remaining being gradually posted through the week (I only need to update the solutions for these).

In addition to VOL2 modification, the following VOL1 focused technology scenarios are being developed and scheduled for delivery the coming weekend:

  1. PPPoE Server
  2. PPPoE Client
  3. EEM: CLI Events
  4. EEM: Monitoring Interface Counters
  5. EEM: Syslog Events
  6. EEM: Working with SNMP
  7. EEM: Embedded Resource Manager
  8. IPv6 EIGRPv6 Setup
  9. IPv6 EIGRPv6 Summarization
  10. IPv6 PIMv6
  11. IPv6 MLD
  12. IPv6 BSR
  13. IPv6 Embedded RP
  14. IPv6 SSM
  15. QoS HQF Bandwidth
  16. QoS HQF Fair-Queue
  17. QoS HQF Random Detection
  18. QoS HQF Shaping

New updated Dynamips labs will be posted this week as well (due to this urgent change to VOL2 we had to delay Dynamips release a little bit). As for remaining VOL4 labs, they have been a bit delayed due to the VOL2 updates but still coming this month.

We’re constantly monitoring the feedback our students give us (within the scope of NDA, of course!) and optimize our products accordingly. Happy studying and thanks for choosing INE!

About Petr Lapukhov, 4xCCIE/CCDE:

Petr Lapukhov's career in IT begain in 1988 with a focus on computer programming, and progressed into networking with his first exposure to Novell NetWare in 1991. Initially involved with Kazan State University's campus network support and UNIX system administration, he went through the path of becoming a networking consultant, taking part in many network deployment projects. Petr currently has over 12 years of experience working in the Cisco networking field, and is the only person in the world to have obtained four CCIEs in under two years, passing each on his first attempt. Petr is an exceptional case in that he has been working with all of the technologies covered in his four CCIE tracks (R&S, Security, SP, and Voice) on a daily basis for many years. When not actively teaching classes, developing self-paced products, studying for the CCDE Practical & the CCIE Storage Lab Exam, and completing his PhD in Applied Mathematics.

Find all posts by Petr Lapukhov, 4xCCIE/CCDE | Visit Website


You can leave a response, or trackback from your own site.

11 Responses to “CCIE RS Workbooks Updates”

 
  1. Kevin says:

    Fantastic. Great work.

  2. Marc La Porte says:

    Hi Petr,

    Thanks!

    Are there any updates planned for VOL3 as well?

    Thanks,
    Marc

  3. DEEPAK ARORA says:

    Hi Petr, I have following suggestions for Vol 1,2 and 4 to take it to next level. I hope you will like it.

    VOL 1 – If following one things can be added to vol 1 that will be a great help with time strategy.

    1. Estimate time of completion should be mentioned for each technology section so that one can judge it’s speed to match up with the requirements.

    Vol 2/4 – 1. Ask the proctor questions for each task, this way students will better in way of asking questions to the proctor accurately as well as also know about how questions can be tricky and can be simplified by asking right questions to the proctor. I saw this thing on Cisco press CCIE R&S practice labs and really liked it.

    2. Documentation URL for each task so that they know where exactly to look for things just in case they don’t remember it. This can also be included in vol 1 as well.

    Regards,
    Deepak Arora

  4. Michael says:

    Can you guys please put out a redistribution tech lab.

  5. AJN says:

    Waiting impatiently for Dynamips workbook updates!

    Great Job Petr!

  6. Nadeem Rafi says:

    I liked Deepak’s idea. That will be a great addition to all workbooks.

  7. Net_OG says:

    I have Anthony’s expanded blueprint and then there are now two posts where Petr has added to the list. This one and the one with OSPF SHAM LINKS and other goodies.
    Maybe it is a good idea to merge Petr’s updates into AS’s 4.0 Expanded BP? I like the expanded Blue Print: one place to see the REAL list of stuff you need to know how to configure and fin documentation for.

  8. Andrei says:

    Deepak’s idea sounds good. at least first point, estimative time

  9. Kannan says:

    Hi Petr,

    I was working on WB Vol1 BGP section “7.43 BGP Conditional Route Injection”.

    I believe the given solution in this section will not fulfill the requirements asked in question.

    Requirement is – Configure BGP Conditional Route Injection on R4 and R6 in such a way that traffic from AS 54 going to the subnet 10.0.1.0/24 enters via R4, while traffic to the subnet 10.0.2.0/24 enters via R6.

    1. The given solution is injecting both prefix on router R6 and advertising to AS#54 and to AS#300 also(as incomplete route-map “FILTER_SPECIFICS” is created but not applied to any neighbor, and this is against the requirement that no other AS# except AS#54 will see the specific prefix).

    My solution is as follows for this section. Could you have a look and suggest if my assumptions for task are correct.

    R2

    int loopback100
    ip address 10.0.0.1 255.255.255.0
    !
    int loopback101
    ip address 10.0.1.1 255.255.255.0
    !
    int loopback102
    ip address 10.0.2.1 255.255.255.0
    !
    int loopback103
    ip address 10.0.3.1 255.255.255.0
    !
    router bgp 200
    network 10.0.0.0 mask 255.255.255.0
    network 10.0.1.0 mask 255.255.255.0
    network 10.0.2.0 mask 255.255.255.0
    network 10.0.3.0 mask 255.255.255.0
    aggregate-address 10.0.0.0 255.255.252.0 summary-only

    ——————-

    R4

    ip prefix-list INJECT_NET permit 10.0.1.0/24
    !
    ip prefix-list AGGREGATE permit 10.0.0.0/22
    !
    ip prefix-list ROUTE_SOURCE permit 155.1.146.1/32
    !
    route-map INJECT_MAP permit 10
    set ip address prefix-list INJECT_NET
    set origin igp
    !
    route-map EXIST_MAP permit 10
    match ip address prefix-list AGGREGATE
    match ip route-source prefix-list ROUTE_SOURCE
    !
    route-map FILTER_SPECIFIC deny 10
    match ip address prefix-list INJECT_NET
    !
    route-map FILTER_SPECIFIC permit 100
    !
    router bgp 100
    bgp inject-map INJECT_MAP exist-map EXIST_MAP
    neighbor 155.1.45.5 route-map FILTER_SPECIFIC out
    neighbor 155.1.146.1 route-map FILTER_SPECIFIC out

    ————-

    R6

    ip prefix-list INJECT_NET permit 10.0.2.0/24
    !
    ip prefix-list AGGREGATE permit 10.0.0.0/22
    !
    ip prefix-list ROUTE_SOURCE permit 155.1.146.1/32
    !
    route-map INJECT_MAP permit 10
    set ip address prefix-list INJECT_NET
    set origin igp
    !
    route-map EXIST_MAP permit 10
    match ip address prefix-list AGGREGATE
    match ip route-source prefix-list ROUTE_SOURCE
    !
    route-map FILTER_SPECIFIC deny 10
    match ip address prefix-list INJECT_NET
    !
    route-map FILTER_SPECIFIC permit 100
    !
    router bgp 100
    bgp inject-map INJECT_MAP exist-map EXIST_MAP
    neighbor 155.1.67.7 route-map FILTER_SPECIFIC out
    neighbor 155.1.146.1 route-map FILTER_SPECIFIC out

  10. Heiko Kreutz says:

    Hi there,
    what happened to HQF? The above blog said, they should have been included a year ago in WB I, but I still cannot find any reference to HQF in that workbook. Did you give up on that topic?

 

Leave a Reply

Categories

CCIE Bloggers