Nov
23

UPDATE: We Have a Winner!

Congratulations to Fredy and Antonis for both answering the question correctly.
Because we only had 2 answers to this contest (and it’s the second time we’ve run it), and they were both correct, as well as both having gone above and beyond the requirements to answer the basic question/problem, but adding additional correct and excellent configurations and annotations — we are awarding each of them the same prize!

At a most basic level, the problem with my configuration was that you cannot used an AS Numbered Instance of EIGRP at the top level to configure SAF (Service Advertisement Framework). Yes, EIGRP does have to have an AS#, but that must come within an EIGRP Virtual Instance Named (VIN)!

They both went above and beyond by pointing out many other great points that are well worth reading.

Congratulations to both of you, and look for my email in relation to your prizes!
By the way, since this is such a cool new technology that holds so much potential for real world production environments, I will do a follow-up blog post outlining the basics and some advanced topics surrounding CCD and SAF. Look for that here, soon.

 

Original Trivia Challenge Below

Time for another INE CCNP Voice Trivia Contest. This week we will start early and give you until Monday 28 November to choose a winner, giving you a bit over four days to come up with the correct responses.

This is actually a re-post of an earlier contest –one containing knowledge that every CCNP Voice engineer must know to pass the CIPT2 (642-457) exam– that never met with a correct answer in the previous run. I have recorded around 4.5 hours of material on just this topic beginning here in this video, so take a look at these videos over the next few days, and see if you can sort out the answer.

Here is the problem that needs solving for this week’s Voice Trivia Contest:

There are three sites, two site running separate CUCM clusters and one site running an instance of CME on that sites only router. The two sites running CUCM clusters each have their own SAF Forwarder router, and those two routers have been configured and are working properly exchanging primary DNs as well as alias prefix routes between them, and each CUCM cluster can dial the other CUCM cluster using the dynamically exchanged 4 digit DN. However, the CME site’s router seems to not have its SAF Forwarder portion configured properly (assume everything else in the router IS configured properly and working), and is not yet receiving or publishing any primary DN or alias prefix routes. Once that problem is resolved, it is also desired that the two CUCM clusters be able to receive the backup PSTN alias prefix routes natively as + (plus) patterns, so that they may use their existing globalized plus dialing patterns (PSTN translation patterns), along with their existing (working) AAR CSS as the patterns for reaching the remote CME site if/when it falls into SRST mode.

So your tasks for this week’s trivia contest are these:

  1. Looking at the code just below these tasks (which is the CCD/SAF portion of the CME site’s router), copy and paste it into your proposed solution in the comments area below, fixing the parts of the code that are incorrect.
    • I should add a few ‘known’ attributes to the equation:
    • SIP over TCP 5060 is the correct signaling protocol, transport and port #
    • The other two sites’ SAF Forwarders are adjacent, established neighbors on EIGRP AS 1
  2. Provide a configuration solution for how you will allow both CUCM clusters the ability to receive the CME advertised alias prefix routes with a + (plus) prefix, so that they may use their existing globalized patterns for matched routing. You may do this by providing a short sentence/paragraph with what you would do to provide for this, or you may update the below configuration if you believe you are able to fix it there in the CME site’s router config.

!
router eigrp 1
 !
 service-family ipv4 autonomous-system 1
  !
  sf-interface Loopback0
   no split-horizon
  exit-sf-interface
  !
 exit-service-family
!
!
voice service saf
 !
 profile trunk-route 1
  session protocol sip interface Loopback0 transport tcp port 5060
 !
 profile dn-block 1 alias-prefix 3120703
  pattern 1 type extension 6XXX
 !
 profile callcontrol 1
  dn-service name Branch2-CME
   trunk-route 1
   dn-block 1
  !
 !
 channel 1 vrouter VO_SAF_R3 asystem 1
  subscribe callcontrol wildcarded
  publish callcontrol 1
 !
!


As always, the winner of this contest will have their choice of any one of these items:

  • $100USD Amazon Gift Card
  • $100USD in GradedLabs Tokens (which is 6.5 Voice rack sessions!)
  • $100USD worth of INE.com online store credit

The rules for this contest are as follows:

  • You must answer any/all questions correctly – this means that the solution provided must fully meet the requirement (i.e. If something else breaks, such as normal dialing, or digit appearance is not as requested, as a result of your answer – it will not be counted as a correct answer)
  • You must submit your answers in the comments section of this post along with a valid email address to reach you for your prize (submissions emailed to INE will not be accepted)
  • If there are multiple, correct respondents, then we will place all of the correct respondents names into an online randomizer – the modern day ‘hat’ if you will
  • We will not allow any of the response comments to be posted here on this blog post (publicly) until the contest is over, so as not to give an unfair advantage to anyone

I’ll be watching the submissions over the next few days, and I will return on Monday to gather up the winners, choose a random name, and post all of the comments along with some of with my own replies and comments, and of course, the correct solution.

Good Luck!
Mark



About Mark Snow, CCIE #14073:

Mark Snow has been actively working with data and traditional telephony as a Network Consulting Engineer since 1995, and has been working with Cisco Call Manager and voice-over technology since 1998. Mark has been actively teaching and developing content for the CCIE Voice track since 2005, and the Security track since 2007. Mark's story with both data and voice technology started out quite young, as he began learning around the age of five from his father who was a patented inventor and a research scientist at AT&T Bell Laboratories. Mark started out on Unix System V and basic analog telephony, and went on from there to large data networking projects with technologies such as Banyan Vines, IPX and of course IP, and large phone systems such as Nortel 61c, Tadiran Coral, Avaya Definity and of course Cisco Unified Communications Manager in both enterprise and 911 PSAP environments across the US and internationally. Mark is also an accomplished pilot and punched his ticket in 2001. When Mark isn't learning, labing, consulting or teaching, he can be found either piloting or possibly jumping out of a perfectly good airplane, hanging off a rock somewhere or else skiing out west. He also might just be enjoying a quiet day at the beach with his wife and two wonderful young kids, Ryleigh and Judah.

Find all posts by Mark Snow, CCIE #14073 | Visit Website


You can leave a response, or trackback from your own site.

3 Responses to “CCNP Voice Trivia Contest :: CCD Dynamic Routing of DNs (Nice Prizes)”

 
  1. [...] would like to point out that we never had a winner for a contest that I held for this contest: CCNP Voice Trivia Contest :: CCD Dynamic Routing of DNs, so I will be publishing it again in the not-too-distant future. So have a look at it now, and see [...]

  2. antonis says:

    router eigrp VO_SAF_R3 // VO_SAF_R3 parameter should match CCD setting in channel vrouter configuration
    !
    service-family ipv4 autonomous-system 1
    !
    sf-interface Loopback0
    no split-horizon
    exit-sf-interface
    !
    exit-service-family
    !
    !
    voice service saf
    !
    call
    timer aar-ageout 2880 // SAF dnDB will flush SRST alias pstn prefixes after two days
    !
    profile trunk-route 1
    session protocol sip interface Loopback0 transport tcp port 5060
    !
    profile dn-block 1 alias-prefix 3120703
    pattern 1 type extension 6XXX
    !
    profile callcontrol 1
    dn-service name Branch2-CME
    trunk-route 1
    dn-block 1
    !
    !
    channel 1 vrouter VO_SAF_R3 asystem 1
    subscribe callcontrol wildcarded
    publish callcontrol 1
    !
    !

    In case of SRST the following SAF plugin dial-peer should be added

    dial-peer voice 1000 voip
    destination-pattern ….
    session target saf

    In CUCM under CCD Requesting Service Configuration, at PSTN Prefix field the + sign should be added, so all requested/learned pstn prefixes would have the +, in order to existing globalized patterns for matched routing to be used. In case + sign exists at PSTN Failover Prepend Digits, in Hosted DN Pattern Configuration Settings, it should be removed.

  3. Fredy says:

    Hi Mark,

    I write the configuration that i think solves the trivia.

    Interface loopback0 –> Interface to include in EIGRP Protocol
    ip address 10.1.1.1 255.255.255.255
    ip rsvp bandwidth
    !
    router eigrp 1 ->> We need to add EIGRP to create the adjacencies.
    network 10.1.1.1 0.0.0.0 –> Loopback0
    network 10.10.10.0 0.0.0.255 –> Our Local Voice Network
    network 10.10.20.0 0.0.0.255 –> Our Local Data Network
    !
    router eigrp SAF –> We need to changed (1) by the Virtual Instance NAME. In this case i will use SAF, and this VIN should be match with VIN SAF Forwarder.
    !
    service-family ipv4 autonomous-system 1
    !
    sf-interface Loopback0
    topology base –> We should use this command in order to enables service-family topology configuration mode
    exit-sf-topology ->> To exit service-family configuration mode
    neighbor 10.2.1.1 loopback0 remote 100 ->> We should add the SAF forwarder’s. I proposed this adressing.
    neighbor 10.3.1.1 loopback0 remote 100
    !
    no split-horizon ->> Use this command to disable split horizon when we have centralized SAF. In this case is unnecessary, we should to remove.
    exit-sf-interface
    !
    exit-service-family
    !
    !
    voice service saf
    !
    profile trunk-route 1
    session protocol sip interface Loopback0 transport tcp port 5060
    !
    profile dn-block 1 alias-prefix 3120703
    pattern 1 type extension 6XXX
    !
    /** This configuration is necessary in order to add +(plus) to patterns configured with type global. Global patterns always have ToDID unset. **/

    profile dn-block 2
    pattern 1 type global 14084567890

    !
    profile callcontrol 1
    dn-service name Branch2-CME
    trunk-route 1
    dn-block 1
    !
    !
    channel 1 vrouter SAF asystem 1 –> We need to math the EIGRP-ID with the EIGRP procces. In this case we use SAF. Change VO_SAF_R3 by SAF.
    subscribe callcontrol wildcarded
    publish callcontrol 1
    !
    !

    I hope that this configuration meets the requeriments to solve the trivia.

    Regards.

 

Leave a Reply

Categories

CCIE Bloggers