Posts Tagged ‘l2tpv3’

Dec
22

We have added some new US and International CCIE Voice bootcamps to our schedule!

With every 10-Day Bootcamp purchase, INE gives you your choice of either:

OR
Continue Reading

Tags: , , , , ,

Dec
15

We are finished with our L2VPN beta testing, and are very happy to report that all 38 of our beta testers reported back not only no issues with connecting to us, but also an incredible experience overall with phones that appear directly connected to their rack switchports, and that behave and function exactly as they did when any of them have previously sat for the CCIE Voice lab exam. We are happy to announce that every one of our Voice racks now fully supports SIX Layer 2 VPN connections – one for each phone.

At INE, we are all about putting as much knowledge in your mind as it can hold, as many tools in your hands as possible, and doing it all for far less than anyone. We offer so many ways of connecting to our Voice racks and often I get asked which method is the best and which they should use. So I thought I would take this time to quickly outline all of the ways we offer to connect to our racks, and then break them down by most-to-least desirable methods for doing so after the break.

Outline of Connection Methods

  1. Layer 2 Hardware VPN – Use Your Own Hardware Cisco IP Phones
    • (This option is the only true way to experience the CCIE Voice lab)
  2. Layer 3 Hardware VPN – Use Your Own Hardware Cisco IP Phones
  3. SSL AnyConnect VPN – Use Our Rack-Connected Phones with FREE Web-Based Remote Control
  4. IPSec (EzVPN) VPN – Use Our Rack-Connected Phones with FREE Web-Based Remote Control
  5. NO VPN AT ALL – Use Our Rack-Connected Phones with FREE Web-Based Remote Control

Continue Reading

Tags: , , , , , , ,

Dec
02

I mentioned a few weeks back in bullet #3 in my post titled “SO Many Voice Updates!” that we would be adding Layer 2 VPN support for our Voice racks. Well, our hardware is in place and tested (by us), and now it is ready to be tested by you!

To start out, we are going to select a few beta customers to try out the service, and work out any kinks that may be there. I will work personally with all beta customers, and any issues will be resolved very quickly. I just want to make sure that we get everything documented properly.

Continue Reading

Tags: , , ,

Jul
29

Updated with 18 Month Plan!

Not only have I updated the post below quite a bit, but I have also now put together a spreadsheet that you are free to download and customize to your liking. It includes both a 12-month plan that closely resembles what is listed below, but it also includes an 18-month plan on the 2nd tab that can be used by those who simply cannot devote as much time as I propose in the below post. Simply change the start date and the rest will cascade. Use this spreadsheet to be able to propose a very comprehensive plan to your boss if you are getting corporate-backing.

Download the 12 and 18-month plan spreadsheet

Introduction

I often get questions in class or via email that go something like “I am just beginning my studies for CCNA Voice – do I really need a two year AAP subscription?” or “How can I best utilize INE’s products to attain the CCIE Voice exam”, or simply “Where should I start?”.

This document seeks to provide you with a detailed guideline to using each of the products that compliment INE’s complete Voice training program. This program structure has been designed under the realistic assumption that you may be able to dedicate roughly 4 days a week, with approximately 4 hours a day (16 hours a week) to some form of study (be it watching our lecture and demo-based VoDs, reading Cisco documentation and books found in our Recommended Voice Reading Book List, or practicing on lab equipment), and be able to span a total duration of roughly 55 weeks from the start of studying for your CCNA Voice exam, and progressing through the CCNP Voice exam, and finally onto being ready to sit for your first CCIE Voice Lab exam attempt. This works out to just around one year of studying, with around 4 weeks off. This could (and probably will) vary, depending on your schedule, as you will undoubtedly need to custom tailor this program a bit to your life. All-in-all, you are going to spend almost 900 hours. I realize that this is a very committed study schedule, and I also wholeheartedly realizeĀ the sacrifice involved to commit fully to such an undertaking, however know now that these are hours that you, later in life, will look back on and attribute to some of the most beneficial that you have ever spent in your professional career. So buckle-up, and prepare yourself for the ride.

Note: It is assumed that before beginning this regiment, that the candidate has already studied for and obtained the necessary CCNA (Routing and Switching) exam. If you have not yet completed this Cisco-prerequisite exam yet, we strongly recommend that you take ourĀ CCNA Associate Course – 640-802 first, and pass that required exam.

Continue Reading

Tags: , , , , , , , , , , ,

Jan
28

Let’s say you get a bunch of inexpensive (but a bit outdated) routers (36XX or 72Xx) and some really nice (maybe not so cheap) Cisco switches (e.g. 3550/3560) and you would like to provide a VPLS-like service to your customers. Since VPLS is a service available only on more powerful Cisco platforms, we have to figure a way to simulate Multipoint Ethernet L2 VPN over a packet switching network (PSN) using only “convenient” point-to-point L2 VPN services.

Let model a situation where we have a number of routers connected over (PSN), with an ethernet switch connected to router at every location:

VPLS with L2TPV3

What we can do, is connect ethernet ports using pseudowires to form a virtual ring topology over PSN. That is, refeferring to our picture, xconnect routers’ ethernet ports counter-clockwise, say xconnect E0/0 of R3 with E0/1 of R4, then E0/0 of R4 with E0/1 of R5 and finally E0/0 of R5 with E0/1 of R3. Effectively, we will form an ethernet ring, partially connected over convenient switches, and partially using L2VPN pseudowires. Router configurations look pretty much similar, for example at R3 we would have something like this


R3:
pseudowire-class PW_CLASS
 encapsulation l2tpv3
 ip local interface Loopback0
!
interface Loopback0
 ip address 150.1.3.3 255.255.255.255

!
! Xconnecting E0/0 of R3 with E0/1 of R4
!
interface Ethernet0/0
 no ip address
 xconnect 150.1.4.4 34 encapsulation l2tpv3 pw-class PW_CLASS

!
! Xconnecting E0/1 of R3 with E0/0 of R5
!
interface Ethernet0/1
 no ip address
 xconnect 150.1.5.5 35 pw-class PW_CLASS

!
! Frame-Relay is used to connect to other routers (PSN network)
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
!
interface Serial1/0.34 point-to-point
 ip address 150.1.34.3 255.255.255.0
 frame-relay interface-dlci 304
!
interface Serial1/0.35 point-to-point
 ip address 150.1.35.3 255.255.255.0
 frame-relay interface-dlci 305 

!
! OSPF is used as a sample IGP
!
router ospf 1
 router-id 150.1.3.3
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0

Speaking honestly, it’s not “classic” VPLS in true sense:

Firstly, STP should be running over ring topology, in order to block redundant ports. One can use star topology and disable STP, but this will introduce a single point of failure into the network. Classic VPLS does not run STP over packet core, only a full-mesh of pseudowires.

Secondly, there is no MAC-address learning for pseudowires, since they are point-to-point in essense. MAC addresses are learned by switches, and this impose a usual scalability restriction (though cisco switches may allow you to scale to a few thousands of MAC addresses in their tables).

However, this is funny and simple example of how you can use a simple concept to come up with a more complicated solution.

Tags: , , , ,

Categories

CCIE Bloggers