blog
    PfR vSeminar Topology and ...
    20 April 13

    PfR vSeminar Topology and Initial Configurations

    Posted byINE
    facebooktwitterlinkedin
    news-featured

    Below is the topology that I will be using for tomorrow's PfR vSeminar. This should work on just about any rack setup as I only used one Ethernet interface on each router. Additionally all of the switches are acting as the hosts (SW1 Host A, SW2 Host B, etc).

    PfR Topology

    The initial configurations are available in the rack control panel for the R&S rental racks (PfR vSeminar Initial Configs) and available below. R1 and R2 are the "external" routers and they are running BGP with each other as later in the vSeminar they will peer with R4 and R5 via eBGP. R4 and R5 have static default routes and are originating a default into OSPF with R5's default having a lower cost making R5 the primary egress router to reach the external networks. Also at the bottom is basic ping script you can use to test your initial configurations.


    R1:

    version 12.4
    no service pad
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    service tcp-small-servers
    !
    hostname Rack1R1
    !
    boot-start-marker
    boot system flash:
    boot-end-marker
    !
    logging buffered 4444096 debugging
    no logging console
    enable secret 5 $1$y2DI$z7s4dcWZpwU7NjVv42Nb40
    !
    no aaa new-model
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    no ip icmp rate-limit unreachable
    ip cef
    !
    no ip domain lookup
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    !
    archive
    log config
    hidekeys
    !
    ip tcp synwait-time 5
    !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.255
    !
    interface Loopback1
    ip address 50.0.0.1 255.255.255.255
    !
    interface FastEthernet0/0
    no shutdown
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.12
    encapsulation dot1Q 12
    ip address 134.1.1.1 255.255.0.0 secondary
    ip address 204.12.1.1 255.255.255.0 secondary
    ip address 50.1.0.1 255.255.255.0
    !
    interface FastEthernet0/0.14
    encapsulation dot1Q 14
    ip address 192.10.14.1 255.255.255.248
    !
    interface FastEthernet0/0.15
    encapsulation dot1Q 15
    ip address 192.10.15.1 255.255.255.248
    !
    router bgp 100
    bgp router-id 1.1.1.1
    bgp log-neighbor-changes
    neighbor 50.1.0.2 remote-as 200
    neighbor 192.10.14.4 remote-as 300
    neighbor 192.10.15.5 remote-as 300
    !
    address-family ipv4
    redistribute connected
    neighbor 50.1.0.2 activate
    neighbor 192.10.14.4 activate
    neighbor 192.10.15.5 activate
    no auto-summary
    no synchronization
    exit-address-family
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.10.14.4
    ip route 0.0.0.0 0.0.0.0 192.10.15.5
    !
    no ip http server
    no ip http secure-server
    !
    control-plane
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    scheduler allocate 20000 1000
    !
    end

    R2:

    version 12.4
    no service pad
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    !
    hostname Rack1R2
    !
    boot-start-marker
    boot system flash:
    boot-end-marker
    !
    logging buffered 4444096 debugging
    no logging console
    enable secret 5 $1$y2DI$z7s4dcWZpwU7NjVv42Nb40
    !
    no aaa new-model
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    no ip icmp rate-limit unreachable
    ip cef
    !
    no ip domain lookup
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    !
    archive
    log config
    hidekeys
    !
    ip tcp synwait-time 5
    !
    interface Loopback0
    ip address 2.2.2.2 255.255.255.255
    !
    interface Loopback2
    ip address 50.0.0.2 255.255.255.255
    !
    interface FastEthernet0/0
    no shutdown
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.12
    encapsulation dot1Q 12
    ip address 134.1.1.2 255.255.0.0 secondary
    ip address 204.12.1.2 255.255.255.0 secondary
    ip address 50.1.0.2 255.255.255.0
    !
    interface FastEthernet0/0.25
    encapsulation dot1Q 25
    ip address 192.10.25.2 255.255.255.248
    !
    router bgp 200
    bgp router-id 2.2.2.2
    bgp log-neighbor-changes
    neighbor 50.1.0.1 remote-as 100
    neighbor 192.10.25.5 remote-as 300
    !
    address-family ipv4
    redistribute connected
    neighbor 50.1.0.1 activate
    neighbor 192.10.25.5 activate
    no auto-summary
    no synchronization
    exit-address-family
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.10.25.5
    !
    no ip http server
    no ip http secure-server
    !
    control-plane
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    scheduler allocate 20000 1000
    !
    end

    R3:

    version 12.4
    no service pad
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    !
    hostname Rack1R3
    !
    boot-start-marker
    boot system flash:
    boot-end-marker
    !
    logging buffered 4444096 debugging
    no logging console
    enable secret 5 $1$y2DI$z7s4dcWZpwU7NjVv42Nb40
    !
    no aaa new-model
    no ip icmp rate-limit unreachable
    ip cef
    !
    no ip domain lookup
    !
    archive
    log config
    hidekeys
    !
    ip tcp synwait-time 5
    !
    interface Loopback0
    ip address 3.3.3.3 255.255.255.255
    ip ospf 1 area 0
    !
    interface FastEthernet0/0
    no shutdown
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.10
    description CONNECTED TO HOST A & B
    encapsulation dot1Q 10
    ip address 10.1.1.3 255.255.255.0
    ip ospf 1 area 0
    !
    interface FastEthernet0/0.34
    encapsulation dot1Q 34
    ip address 173.1.34.3 255.255.255.0
    ip ospf 1 area 0
    !
    interface FastEthernet0/0.35
    description INTERNAL INTERFACE TO R5
    encapsulation dot1Q 35
    ip address 173.1.35.3 255.255.255.0
    ip ospf 1 area 0
    !
    interface FastEthernet0/0.36
    description INTERNAL INTERFACE TO R6
    encapsulation dot1Q 36
    ip address 173.1.36.3 255.255.255.0
    ip ospf 1 area 0
    !
    interface FastEthernet0/0.172
    description CONNECTED TO HOST C & D
    encapsulation dot1Q 172
    ip address 172.16.1.3 255.255.255.0
    ip ospf 1 area 0
    !
    router ospf 1
    router-id 3.3.3.3
    log-adjacency-changes
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    control-plane
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    end

    R4:

    version 12.4
    no service pad
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    !
    hostname Rack1R4
    !
    boot-start-marker
    boot system flash:
    boot-end-marker
    !
    logging message-counter syslog
    logging buffered 4444096
    no logging console
    enable secret 5 $1$y2DI$z7s4dcWZpwU7NjVv42Nb40
    !
    no aaa new-model
    dot11 syslog
    ip source-route
    no ip icmp rate-limit unreachable
    !
    ip cef
    no ip domain lookup
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    archive
    log config
    hidekeys
    !
    ip tcp synwait-time 5
    !
    policy-map PM_512k
    class class-default
    shape average 512000
    !
    interface Loopback0
    ip address 4.4.4.4 255.255.255.255
    ip ospf 1 area 0
    !
    interface FastEthernet0/0
    no shutdown
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.14
    description EXTERNAL INTERFACE TO R1
    encapsulation dot1Q 14
    ip address 192.10.14.4 255.255.255.248
    ip ospf 1 area 0
    service-policy output PM_512k
    !
    interface FastEthernet0/0.34
    description INTERNAL INTERFACE TO R3
    encapsulation dot1Q 34
    ip address 173.1.34.4 255.255.255.0
    ip ospf 1 area 0
    !
    router ospf 1
    router-id 4.4.4.4
    log-adjacency-changes
    passive-interface FastEthernet0/0.14
    default-information originate always
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.10.14.1
    no ip http server
    no ip http secure-server
    !
    control-plane
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line aux 0
    line vty 0 4
    privilege level 15
    password cisco
    login
    length 0
    !
    scheduler allocate 20000 1000
    !
    end

    R5:

    version 12.4
    no service pad
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    !
    hostname Rack1R5
    !
    boot-start-marker
    boot system flash:
    warm-reboot
    boot-end-marker
    !
    logging message-counter syslog
    logging buffered 4444096
    no logging console
    enable secret 5 $1$y2DI$z7s4dcWZpwU7NjVv42Nb40
    !
    no aaa new-model
    dot11 syslog
    ip source-route
    no ip icmp rate-limit unreachable
    !
    ip cef
    no ip domain lookup
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    archive
    log config
    hidekeys
    !
    ip tcp synwait-time 5
    !
    policy-map PM_256k
    class class-default
    shape average 256000
    policy-map PM_512k
    class class-default
    shape average 512000
    !
    interface Loopback0
    ip address 5.5.5.5 255.255.255.255
    ip ospf 1 area 0
    !
    interface FastEthernet0/0
    no shutdown
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.15
    description EXTERNAL INTERFACE TO R1
    encapsulation dot1Q 15
    ip address 192.10.15.5 255.255.255.248
    ip ospf 1 area 0
    service-policy output PM_512k
    !
    interface FastEthernet0/0.25
    description EXTERNAL INTERFACE TO R2
    encapsulation dot1Q 25
    ip address 192.10.25.5 255.255.255.248
    ip ospf 1 area 0
    service-policy output PM_256k
    !
    interface FastEthernet0/0.35
    description INTERNAL INTERFACE TO R3
    encapsulation dot1Q 35
    ip address 173.1.35.5 255.255.255.0
    ip ospf 1 area 0
    !
    router ospf 1
    router-id 5.5.5.5
    log-adjacency-changes
    passive-interface FastEthernet0/0.15
    passive-interface FastEthernet0/0.25
    default-information originate always metric 10
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.10.15.1
    ip route 0.0.0.0 0.0.0.0 192.10.25.2
    no ip http server
    no ip http secure-server
    !
    control-plane
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line aux 0
    line vty 0 4
    privilege level 15
    password cisco
    login
    length 0
    !
    scheduler allocate 20000 1000
    !
    end

    R6:

    version 12.4
    no service pad
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    !
    hostname Rack1R6
    !
    boot-start-marker
    boot system flash:
    warm-reboot
    boot-end-marker
    !
    logging message-counter syslog
    logging buffered 4444096
    no logging console
    enable secret 5 $1$y2DI$z7s4dcWZpwU7NjVv42Nb40
    !
    no aaa new-model
    dot11 syslog
    ip source-route
    no ip icmp rate-limit unreachable
    !
    ip cef
    no ip domain lookup
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    archive
    log config
    hidekeys
    !
    ip tcp synwait-time 5
    !
    interface Loopback0
    ip address 6.6.6.6 255.255.255.255
    ip ospf 1 area 0
    !
    interface GigabitEthernet0/0
    no shutdown
    no ip address
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/0.36
    description INTERNAL INTERFACE TO R3
    encapsulation dot1Q 36
    ip address 173.1.36.6 255.255.255.0
    ip ospf 1 area 0
    !
    router ospf 1
    router-id 6.6.6.6
    log-adjacency-changes
    !
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !
    control-plane
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line aux 0
    line vty 0 4
    privilege level 15
    password cisco
    login
    length 0
    !
    scheduler allocate 20000 1000
    !
    end

    SW1:

    vtp mode transparent
    !
    no vtp password
    vlan 10
    name VLAN0010
    vlan 12
    name VLAN0012
    vlan 14
    name VLAN0014
    vlan 15
    name VLAN0015
    vlan 25
    name VLAN0025
    vlan 34
    name VLAN0034
    vlan 35
    name VLAN0035
    vlan 36
    name VLAN0036
    vlan 172
    name VLAN0172
    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname HOST-A
    !
    boot-start-marker
    boot-end-marker
    !
    no logging console
    enable password cisco
    !
    no aaa new-model
    system mtu routing 1500
    ip subnet-zero
    no ip domain-lookup
    !
    spanning-tree mode rapid-pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    interface range FastEthernet0/1-24
    no shutdown
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    !
    interface Vlan10
    ip address 10.1.1.100 255.255.255.0
    !
    ip default-gateway 10.1.1.3
    ip classless
    no ip http server
    no ip http secure-server
    !
    control-plane
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line vty 0 4
    password cisco
    login
    line vty 5 15
    password cisco
    login
    !
    end

    SW2:

    vtp mode transparent
    !
    no vtp password
    vlan 10
    name VLAN0010
    vlan 12
    name VLAN0012
    vlan 14
    name VLAN0014
    vlan 15
    name VLAN0015
    vlan 25
    name VLAN0025
    vlan 34
    name VLAN0034
    vlan 35
    name VLAN0035
    vlan 36
    name VLAN0036
    vlan 172
    name VLAN0172
    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname HOST-B
    !
    boot-start-marker
    boot-end-marker
    !
    no logging console
    enable password cisco
    !
    no aaa new-model
    system mtu routing 1500
    ip subnet-zero
    no ip domain-lookup
    !
    spanning-tree mode rapid-pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    interface range FastEthernet0/1-24
    no shutdown
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    !
    !
    interface Vlan10
    ip address 10.1.1.101 255.255.255.0
    !
    ip default-gateway 10.1.1.3
    ip classless
    no ip http server
    no ip http secure-server
    !
    control-plane
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line vty 0 4
    password cisco
    login
    line vty 5 15
    password cisco
    login
    !
    end

    SW3:

    vtp mode transparent
    !
    no vtp password
    vlan 10
    name VLAN0010
    vlan 12
    name VLAN0012
    vlan 14
    name VLAN0014
    vlan 15
    name VLAN0015
    vlan 25
    name VLAN0025
    vlan 34
    name VLAN0034
    vlan 35
    name VLAN0035
    vlan 36
    name VLAN0036
    vlan 172
    name VLAN0172
    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname HOST-C
    !
    no logging console
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    no ip domain-lookup
    !
    vtp file vlan.dat
    !
    spanning-tree mode rapid-pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    interface range FastEthernet0/1-24
    no shutdown
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface Vlan172
    ip address 172.16.1.100 255.255.255.0
    !
    ip default-gateway 172.16.1.3
    ip classless
    no ip http server
    no ip http secure-server
    !
    control-plane
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line vty 0 4
    password cisco
    login
    line vty 5 15
    password cisco
    login
    !
    end

    SW4:

    vtp mode transparent
    !
    no vtp password
    vlan 10
    name VLAN0010
    vlan 12
    name VLAN0012
    vlan 14
    name VLAN0014
    vlan 15
    name VLAN0015
    vlan 25
    name VLAN0025
    vlan 34
    name VLAN0034
    vlan 35
    name VLAN0035
    vlan 36
    name VLAN0036
    vlan 172
    name VLAN0172
    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname HOST-D
    !
    no logging console
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    no ip domain-lookup
    !
    vtp file vlan.dat
    !
    spanning-tree mode rapid-pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    interface range FastEthernet0/1-24
    no shutdown
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface Vlan172
    ip address 172.16.1.101 255.255.255.0
    !
    ip default-gateway 172.16.1.3
    ip classless
    no ip http server
    no ip http secure-server
    !
    control-plane
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line vty 0 4
    password cisco
    login
    line vty 5 15
    password cisco
    login
    !
    end

    Ping Script:

    tclsh
    foreach i {
    1.1.1.1
    50.1.0.1
    50.0.0.1
    134.1.1.1
    204.12.1.1
    192.10.15.1
    192.10.14.1
    2.2.2.2
    50.0.0.2
    50.1.0.2
    134.1.1.2
    204.12.1.2
    192.10.25.2
    3.3.3.3
    10.1.1.3
    173.1.36.3
    173.1.35.3
    173.1.34.3
    172.16.1.3
    4.4.4.4
    173.1.34.4
    192.10.14.4
    5.5.5.5
    173.1.35.5
    192.10.15.5
    192.10.25.5
    6.6.6.6
    173.1.36.6
    10.1.1.100
    10.1.1.101
    172.16.1.100
    172.16.1.101
    } { puts [exec "ping $i"]}

    Hey! Don’t miss anything - subscribe to our newsletter!

    © 2022 INE. All Rights Reserved. All logos, trademarks and registered trademarks are the property of their respective owners.
    instagram Logofacebook Logotwitter Logolinkedin Logoyoutube Logo