Jun
28

The IOS XR Introduction vSeminar that I ran during our last CCIE Service Provider Version 3.0 Bootcamp is now available for viewing. This vSeminar covers the basics of interacting with the IOS XR interface, using the admin mode for verifying RP and Line Card hardware properties, configuring Secure Domain Routers (SDRs), managing configuration commits and rollbacks, and other first steps of the primary differences between regular IOS and IOS XR.


http://www.youtube.com/watch?v=-sGBfFgxIPM

For those of you interested in learning more about IOS XR be sure to check out our CCIE Service Provider Version 3.0 Advanced Technologies Class on Demand, our CCIE Service Provider Version 3.0 Lab Workbook, and our CCIE Service Provider Version 3.0 Rack Rentals.

Enjoy!

Jun
25

With the growing popularity of our CCIE Service Provider Version 3.0 Rack Rentals, which include IOS XR, our support staff has been receiving an increasing number of trouble tickets where users are reporting physical connectivity problems of the IOS XR routers to their attached Ethernet switches.  In 99% of these cases the problem doesn't stem from physical layer 1 issues, but instead from a misunderstanding of how IOS XR link negotiation works, since it is different than most other platforms.  While the fix for this problem is very simple, it's one of those issues that can be incredibly frustrating for candidates learning IOS XR for the first time, since it's really demotivating to not even be able to ping your directly connected layer 2 neighbor! :)  First, let's examine the problem.

XR1 is connected to SW1 via GigabitEthernet as follows:

Both XR1 and SW1 have default configurations. Next, XR1 is configured with an IPv4 address on its link connecting to SW1, and SW1 is configured with a VLAN interface in the same subnet.

RP/0/0/CPU0:XR1#config t
Mon Jun 25 14:45:32.900 UTC
RP/0/0/CPU0:XR1(config)#int gig0/1/0/0
RP/0/0/CPU0:XR1(config-if)#ipv4 address 10.0.0.1/24
RP/0/0/CPU0:XR1(config-if)#commit
RP/0/0/CPU0:Jun 25 14:45:47.339 : config[65706]: %MGBL-CONFIG-6-DB_COMMIT : Configuration committed by user 'xradmin'. Use 'show configuration commit changes 1000000308' to view the changes.
RP/0/0/CPU0:XR1(config-if)#end
RP/0/0/CPU0:Jun 25 14:45:48.924 : config[65706]: %MGBL-SYS-5-CONFIG_I : Configured from console by xradmin
RP/0/0/CPU0:XR1#show ipv4 interface brief
Mon Jun 25 14:46:01.889 UTC

Interface IP-Address Status Protocol
MgmtEth0/0/CPU0/0 unassigned Up Up
MgmtEth0/0/CPU0/1 unassigned Up Up
MgmtEth0/0/CPU0/2 unassigned Down Down
GigabitEthernet0/1/0/0 10.0.0.1 Up Up
GigabitEthernet0/1/0/1 unassigned Up Up
GigabitEthernet0/1/0/2 unassigned Up Up
GigabitEthernet0/1/0/3 unassigned Up Up
POS0/6/0/0 unassigned Up Up

SW1#show run int gig0/1
Building configuration...

Current configuration : 51 bytes
!
interface GigabitEthernet0/1
port-type nni
end

SW1#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW1(config)#int vlan 1
SW1(config-if)#ip address 10.0.0.2 255.255.255.0
SW1(config-if)#no shut
SW1(config-if)#end
SW1#

XR1's link shows up/up in the show ipv4 interface brief output, so you would assume that these hosts would have connectivity. Verification shows otherwise though.

RP/0/0/CPU0:XR1#ping 10.0.0.2
Mon Jun 25 14:58:05.972 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
..U..
Success rate is 0 percent (0/5)

Further digging shows that SW1's link appears like there is a layer 1 problem:

SW1#show int gig0/1 status

Port Name Status Vlan Duplex Speed Type
Gi0/1 notconnect 1 full 1000 1000BaseSX SFP

This is normally where the rack rental user submits the support ticket ;)  A little digging in the documentation for IOS XR shows us what the problem is though:

By default, autonegotiation of Ethernet linecard ports is off.  Doh! :)  To get the link up then the fix is simple.  We either have to disable negotiation on the switch side, or enable negotiation on the router side.  The configuration of both options would be as follows:

SW1#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW1(config)#int gig0/1
SW1(config-if)#speed nonegotiate
SW1(config-if)#end
SW1#
*Mar 1 00:18:53.921: %SYS-5-CONFIG_I: Configured from console by console
*Mar 1 00:18:54.173: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to up
*Mar 1 00:18:55.179: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
*Mar 1 00:19:23.055: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
SW1#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/203/1007 ms
SW1#

SW1#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW1(config)#default int gig0/1
Interface GigabitEthernet0/1 set to default configuration
SW1(config)#end
SW1#
*Mar 1 00:20:01.844: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down
*Mar 1 00:20:01.844: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
*Mar 1 00:20:02.045: %SYS-5-CONFIG_I: Configured from console by console
*Mar 1 00:20:02.876: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to down
SW1#

RP/0/0/CPU0:XR1#config t
Mon Jun 25 15:09:56.192 UTC
RP/0/0/CPU0:XR1(config)#int gig0/1/0/0
RP/0/0/CPU0:XR1(config-if)#negotiation auto
RP/0/0/CPU0:XR1(config-if)#commit
RP/0/0/CPU0:Jun 25 15:10:06.300 : config[65706]: %MGBL-CONFIG-6-DB_COMMIT : Configuration committed by user 'xradmin'. Use 'show configuration commit changes 1000000312' to view the changes.

SW1#
*Mar 1 00:20:27.857: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to up
*Mar 1 00:20:28.863: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
*Mar 1 00:20:56.873: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
SW1#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/203/1006 ms

Tada! Like I said, it's a very simple solution to the problem, but it's one of those things that if you're not in the know, you're out of luck. Can you imagine going to the CCIE Lab Exam and then failing because you can't get your links into the up/up state? Ouch! :)

For those of you interested in learning more about IOS XR be sure to check out our CCIE Service Provider Version 3.0 Advanced Technologies Class on Demand, our CCIE Service Provider Version 3.0 Lab Workbook, and our CCIE Service Provider Version 3.0 Rack Rentals.

Thanks!

May
10

Update: Congrats to Mark, our winner of 100 rack rental tokens for the first correct answer, that XR2 is missing a BGP router-id.  In regular IOS, a router-id is chosen based on the highest Loopback interface.  If there is no Loopback interface the highest IP address of all up/up interfaces is chosen.  In the case of IOS XR however, the router-id will not be chosen from a physical link.  It will only be chosen from the highest Loopback interface, or from the manual router-id command.  Per the Cisco documentation:

BGP Router Identifier

For BGP sessions between neighbors to be established, BGP must be assigned a router ID. The router ID is sent to BGP peers in the OPEN message when a BGP session is established.

BGP attempts to obtain a router ID in the following ways (in order of preference):

  • By means of the address configured using the bgp router-id command in router configuration mode.
  • By using the highest IPv4 address on a loopback interface in the system if the router is booted with saved loopback address configuration.
  • By using the primary IPv4 address of the first loopback address that gets configured if there are not any in the saved configuration.

If none of these methods for obtaining a router ID succeeds, BGP does not have a router ID and cannot establish any peering sessions with BGP neighbors. In such an instance, an error message is entered in the system log, and the show bgp summary command displays a router ID of 0.0.0.0.

After BGP has obtained a router ID, it continues to use it even if a better router ID becomes available. This usage avoids unnecessary flapping for all BGP sessions. However, if the router ID currently in use becomes invalid (because the interface goes down or its configuration is changed), BGP selects a new router ID (using the rules described) and all established peering sessions are reset.

Since XR2 in this case does not have a Loopback configured, the BGP process cannot initialize.  The kicker with this problem is that the documentation states that when this problem occurs you should see that "an error message is entered in the system log", however in this case a Syslog was not generated about the error.  At least this is the last time this problem will bite me ;)

 


Today while working on additional content for our CCIE Service Provider Version 3.0 Lab Workbook I had one of those epic brain fart moments.  What started off as work on (what I thought was) a fairly simply design ended up as a 2 hour troubleshooting rabbit hole of rolling back config snippets one by one, debugging, and basically overall misery that can be perfectly summed up by this GIF of a guy smashing his head against his keyboard. :)

The scenario in question was a BGP peering between two IOS XR routers.  One was the PE of an MPLS L3VPN network and one was the CE.  As I've done this config literally hundreds of times in the past I could not for the life of me figure out why the BGP peering would not establish.  The relevant snippet of the topology diagram is as follows:

Since this scenario caused me so much pleasure I am offering 100 tokens good for CCIE Service Provider Version 3.0 Rack Rentals - or any of our other Routing & Switching rack rentals & mock labs, Security rack rentals, or Voice rack rentals - to whoever the first person is that can tell me why did these neighbors not establish a BGP peering.  The relevant outputs needed to troubleshoot the problem can be found below.  I still haven't decided whether I'm going to leave this problem in the workbook or not since it's such a mean one :)  Good luck!

 

 

<strong>RP/0/0/CPU0:XR1#show run</strong>
Fri May 11 00:34:38.563 UTC
Building configuration...
!! IOS XR Configuration 3.9.1
!! Last configuration change at Fri May 11 00:32:50 2012 by xr1
!
hostname XR1
username xr1
group root-lr
password 7 13061E010803
!
vrf ABC
address-family ipv4 unicast
import route-target
26:65001
!
export route-target
26:65001
!
!
!
line console
exec-timeout 0 0
!
ipv4 access-list PE_ROUTERS
10 permit ipv4 host 1.1.1.1 any
20 permit ipv4 host 2.2.2.2 any
30 permit ipv4 host 5.5.5.5 any
40 permit ipv4 host 19.19.19.19 any
!
interface Loopback0
ipv4 address 19.19.19.19 255.255.255.255
!
interface GigabitEthernet0/1/0/0
ipv4 address 172.19.10.19 255.255.255.0
!
interface GigabitEthernet0/1/0/1
ipv4 address 26.3.19.19 255.255.255.0
!
interface POS0/6/0/0
vrf ABC
ipv4 address 10.19.20.19 255.255.255.0
!
route-policy PASS
pass
end-policy
!
router isis 1
is-type level-2-only
net 49.0001.0000.0000.0019.00
address-family ipv4 unicast
mpls ldp auto-config
!
interface Loopback0
passive
address-family ipv4 unicast
!
!
interface GigabitEthernet0/1/0/1
point-to-point
hello-password hmac-md5 encrypted 022527722E
address-family ipv4 unicast
!
!
!
router bgp 26
address-family ipv4 unicast
!
! address-family ipv4 unicast
address-family vpnv4 unicast
!
neighbor-group PE_ROUTERS
remote-as 26
update-source Loopback0
address-family vpnv4 unicast
!
!
neighbor 1.1.1.1
use neighbor-group PE_ROUTERS
!
neighbor 2.2.2.2
use neighbor-group PE_ROUTERS
!
neighbor 5.5.5.5
use neighbor-group PE_ROUTERS
!
vrf ABC
rd 26:65001
address-family ipv4 unicast
!
neighbor 10.19.20.20
remote-as 65001
address-family ipv4 unicast
route-policy PASS in
route-policy PASS out
as-override
!
!
!
!
mpls ldp
label
allocate for PE_ROUTERS
!
!
end

RP/0/0/CPU0:XR1#

<strong>RP/0/3/CPU0:XR2#show run </strong>
Fri May 11 00:35:04.932 UTC
Building configuration...
!! IOS XR Configuration 3.9.1
!! Last configuration change at Fri May 11 00:30:30 2012 by xr2
!
hostname XR2
logging console debugging
username xr2
group root-lr
password 7 00071A150754
!
cdp
line console
exec-timeout 0 0
!
interface GigabitEthernet0/4/0/0
ipv4 address 10.20.20.20 255.255.255.0
ipv6 address 2001:10:20:20::20/64
!
interface POS0/7/0/0
ipv4 address 10.19.20.20 255.255.255.0
ipv6 address 2001:10:19:20::20/64
!
route-policy PASS
pass
end-policy
!
router bgp 65001
address-family ipv4 unicast
!
neighbor 10.19.20.19
remote-as 26
address-family ipv4 unicast
route-policy PASS in
route-policy PASS out
!
!
!
end

RP/0/3/CPU0:XR2#

RP/0/0/CPU0:XR1#show bgp vrf ABC ipv4 unicast summary 
Fri May 11 00:34:29.712 UTC
BGP VRF ABC, state: Active
BGP Route Distinguisher: 26:65001
VRF ID: 0x60000002
BGP router identifier 19.19.19.19, local AS number 26
BGP table state: Active
Table ID: 0xe0000002
BGP main routing table version 1

BGP is operating in STANDALONE mode.

Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 1 1 1 1 1 1

Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
10.19.20.20 0 65001 2 7 0 0 0 00:03:59 Idle

 
<strong>RP/0/3/CPU0:XR2#show bgp ipv4 unicast summary</strong>
Fri May 11 00:35:02.278 UTC
BGP router identifier 0.0.0.0, local AS number 65001
BGP generic scan interval 60 secs
BGP table state: Active
Table ID: 0xe0000000
BGP main routing table version 1
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.

Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 1 1 1 1 1 1

Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
10.19.20.19 0 26 2 2 0 0 0 00:04:31 Active

 
RP/0/0/CPU0:XR1#show bgp vrf ABC ipv4 unicast neighbors 
Fri May 11 00:34:18.708 UTC

BGP neighbor is 10.19.20.20, vrf ABC
Remote AS 65001, local AS 26, external link
Remote router ID 0.0.0.0
BGP state = Idle
Last read 00:00:00, Last read before reset 00:04:10
Hold time is 180, keepalive interval is 60 seconds
Configured hold time: 180, keepalive: 60, min acceptable hold time: 3
Last write 00:00:15, attempted 53, written 53
Second last write 00:01:01, attempted 53, written 53
Last write before reset 00:04:10, attempted 72, written 72
Second last write before reset 00:04:15, attempted 53, written 53
Last write pulse rcvd May 11 00:34:02.927 last full not set pulse count 9
Last write pulse rcvd before reset 00:04:10
Socket not armed for io, not armed for read, not armed for write
Last write thread event before reset 00:04:10, second last 00:04:10
Last KA expiry before reset 00:00:00, second last 00:00:00
Last KA error before reset 00:00:00, KA not sent 00:00:00
Last KA start before reset 00:00:00, second last 00:00:00
Precedence: internet
Enforcing first AS is enabled
Received 2 messages, 0 notifications, 0 in queue
Sent 7 messages, 0 notifications, 0 in queue
Minimum time between advertisement runs is 0 secs

For Address Family: IPv4 Unicast
BGP neighbor version 0
Update group: 0.2
Route refresh request: received 0, sent 0
Policy for incoming advertisements is PASS
Policy for outgoing advertisements is PASS
0 accepted prefixes, 0 are bestpaths
Cumulative no. of prefixes denied: 0.
Prefix advertised 0, suppressed 0, withdrawn 0
Maximum prefixes allowed 524288
Threshold for warning message 75%, restart interval 0 min
AS override is set
An EoR was not received during read-only mode
Last ack version 0, Last synced ack version 0
Outstanding version objects: current 0, max 0

Connections established 1; dropped 1
Local host: 10.19.20.19, Local port: 19432
Foreign host: 10.19.20.20, Foreign port: 179
Last reset 00:00:15, due to Peer closing down the session
Peer reset reason: Remote closed the session (Connection timed out)
Time since last notification sent to neighbor: 00:02:11
Error Code: administrative shutdown
Notification data sent:
None

<strong>RP/0/3/CPU0:XR2#show bgp ipv4 unicast neighbors </strong>
Fri May 11 00:34:58.427 UTC

BGP neighbor is 10.19.20.19
Remote AS 26, local AS 65001, external link
Remote router ID 0.0.0.0
BGP state = Active
Last read 00:00:00, Last read before reset 00:04:50
Hold time is 180, keepalive interval is 60 seconds
Configured hold time: 180, keepalive: 60, min acceptable hold time: 3
Last write 00:04:50, attempted 19, written 19
Second last write 00:04:50, attempted 53, written 53
Last write before reset 00:04:50, attempted 19, written 19
Second last write before reset 00:04:50, attempted 53, written 53
Last write pulse rcvd May 11 00:30:08.305 last full not set pulse count 4
Last write pulse rcvd before reset 00:04:50
Socket not armed for io, not armed for read, not armed for write
Last write thread event before reset 00:04:50, second last 00:04:50
Last KA expiry before reset 00:00:00, second last 00:00:00
Last KA error before reset 00:00:00, KA not sent 00:00:00
Last KA start before reset 00:04:50, second last 00:00:00
Precedence: internet
Enforcing first AS is enabled
Received 2 messages, 0 notifications, 0 in queue
Sent 2 messages, 0 notifications, 0 in queue
Minimum time between advertisement runs is 30 secs

For Address Family: IPv4 Unicast
BGP neighbor version 0
Update group: 0.2
Route refresh request: received 0, sent 0
Policy for incoming advertisements is PASS
Policy for outgoing advertisements is PASS
0 accepted prefixes, 0 are bestpaths
Cumulative no. of prefixes denied: 0.
Prefix advertised 0, suppressed 0, withdrawn 0
Maximum prefixes allowed 524288
Threshold for warning message 75%, restart interval 0 min
An EoR was not received during read-only mode
Last ack version 0, Last synced ack version 0
Outstanding version objects: current 0, max 0

Connections established 1; dropped 1
Local host: 10.19.20.20, Local port: 60056
Foreign host: 10.19.20.19, Foreign port: 179
Last reset 00:02:27, due to Interface flap
Time since last notification sent to neighbor: 00:05:07
Error Code: administrative reset
Notification data sent:
None


                        
May
02

CCIE SPv3 Rack Rentals - which include IOS XR - are now out of beta and available for normal scheduling via the INE Members' Site. The rack topology is based on our CCIE Service Provider Version 3.0 Lab Workbook and the CCIE Service Provider Version 3.0 Advanced Technologies Class.

Currently each session costs 20 tokens, and each session is 3 hours long. If you purchase tokens in bulk this basically means that SPv3 rack time is around $3 per hour. Token based sessions start on Monday May 7th. People who booked beta sessions before this time (i.e. through Sunday) will still maintain their free sessions. Anyone who booked a beta session on Monday May 7th or later has had your session removed. You can of course add them back through the scheduler, but the sessions are no longer free to book after the end of this weekend.

A brief video on how to use the new scheduling system and SPv3 Rack Rentals is available here.

We’re continuing to add functionality to the new scheduler and its control panel, which includes choosing a config to pre-load before a session starts via the control panel, remote power control via the control panel, loading product configs, saving your current configs, renaming your previously saved configs, downloading your previously saved configs, and re-loading your previously saved configs onto a current session or session scheduled in the future.

If anyone runs into any problems with the scheduler or any of its features please submit feedback so we can get these issues addressed as soon as possible.

Thanks and good luck in your studies!

Apr
27

INE is proud to announce that our long awaited CCIE Service Provider Version 3.0 Rack Rentals are now available, which includes access to IOS XR routers! Furthermore during the initial beta testing of our new rack scheduling system, SPv3 rack rentals are FREE to book! Our new rack scheduler is easier to use than the previous version, and breaks rack sessions down into 3 hour blocks as opposed to the previous 6 hour blocks, which allows for more granularity and affordability in your study schedule. The new scheduler will remain in beta for the next week or so, during which sessions are free to book, but are limited to 1 concurrent session scheduled per customer. Below is a short HOWTO video that I created on using the new scheduling system:

For those of you on mobile platforms the direct link is http://m.youtube.com/watch?v=4DzgoiS9tPI

Additionally a new update has been posted to the CCIE SPv3 Workbook, which now includes the first Full Scale Lab. These updates can be found in the Workbooks tab of the members site, as seen in the above video.

Mar
27

INE is proud to announce that our long awaited CCIE Service Provider Lab Workbook Version 3.0 is now available!  The initial pre-release of the workbook contains over 500 pages of technology focused labs to help you prepare for Cisco’s newest CCIE Service Provider Lab Exam.  Similar to other “rough cut” books, the pre-release of the workbook is for students that want to begin work on their hands-on preparation for the lab exam without further delay.  Over the next few weeks the workbook will be updated to include more technology labs, along with the full scale labs.  The workbook includes a GNS3/Dynamips .net file that is compatible with the topology, and rack rentals that include IOS XR will be available soon.  A sample of the workbook can be found here.

INE’s CCIE Service Provider Lab Workbook Version 3.0 is broken down into two main sections , Advanced Technologies Labs and Full Scale Labs.  The first workbook section, the Advanced Technologies Labs, is the hands on practice companion to INE’s CCIE Service Provider Advanced Technologies Class Version 3.0.  This section consists of hands-on, individually-focused, advanced technology labs that present topics in an easy to follow, goal-oriented step-by-step approach.  The purpose of this section is to isolate each topic on its own so that you are able to see firsthand the various ways to configure each technology. By understanding these fundamental technologies, you will then be able to predict advanced and sometimes subtle interactions when configuring multiple technologies together.  The second workbook section, Full Scale Labs, consists of 8-hour lab scenarios that are designed to simulate the actual CCIE Service Provider Lab Exam, and at the same time illustrate the principles behind the technologies that it covers.

The recommended approach for using this workbook is as follows:

  • Watch the videos in the CCIE SPv3 Advanced Technologies Class
  • Follow the recommended readings from class, including the Cisco Documentation
  • Configure the associated labs in the Advanced Technologies Labs section
  • Revisit the videos and readings for further clarification
  • Configure the labs in the Full Scale Labs section
  • Take and pass the CCIE SPv3 Lab Exam!

The physical topology for INE’s CCIE Service Provider Lab Workbook Version 3.0 uses 10 routers and 2 switches, which include a mix of 7200s, 2600s, XR 12000s, Catalyst ME3400s, and Catalyst 3550s.  This topology has the flexibility to mimic the requirements of Cisco’s actual CCIE Service Provider Version 3.0 hardware blueprint, while still minimizing the cost for users building their own lab at home or work, and allowing for users to run the regular IOS portion of the topology in GNS3/Dynamips.

Specifically the platforms used in the development of this workbook are as follows:

Physical wiring for the topology is as follows:

 

 

Mar
05

I've been getting a lot of emails recently asking when our updated CCIE Service Provider Version 3.0 Workbooks and Rack Rentals are going to be released.  And the answer is... soon :)  In fact sooner than ever.  We're looking at somewhere around the end of March for the release of both the updated Workbook and Rack Rentals.  The updated Workbook will be broken down into two sections, Technology Labs and Full Scale Labs.  Essentially this will be the merging of the previous Volume 1 and Volume 2 workbooks into a single workbook that has two parts.  A sample of the Technology Labs section of the CCIE SPv3 Workbook can be found here.

The technology labs closely follow the flow of our CCIE Service Provider Version 3.0 Advanced Technologies Class-on-Demand.  The idea being that you will be able to watch the videos and then follow along with the hands-on portion of the technology based labs, or do the technology based labs and then fall back to the videos for sections that you don't fully understand.

As for the hardware requirements of the Workbook everything that is regular IOS based will be able to be configured on Dynamips/GNS3, however as there is not yet a public virtualization solution for IOS XR this means that you'll need hands-on experience with real IOS XR routers.  You will be able to do this through our rack rentals, or the racks of several other vendors that will be compatible with our topology.

More information will be made available as the final release of the Workbooks and Rack Rentals approach.

Happy Labbing!

Oct
18

One of our most anticipated products of the year - INE's CCIE Service Provider v3.0 Advanced Technologies Class - is now complete!  The videos from class are in the final stages of post production and will be available for streaming and download access later this week.  Download access can be purchased here for $299.  Streaming access is available for All Access Pass subscribers for as low as $65/month!  AAP members can additionally upgrade to the download version for $149.

At roughly 40 hours, the CCIE SPv3 ATC covers the newly released CCIE Service Provider version 3 blueprint, which includes the addition of IOS XR hardware. This class includes both technology lectures and hands on configuration, verification, and troubleshooting on both regular IOS and IOS XR. Class topics include Catalyst ME3400 switching, IS-IS, OSPF, BGP, MPLS Layer 3 VPNs (L3VPN), Inter-AS MPLS L3VPNs, IPv6 over MPLS with 6PE and 6VPE, AToM and VPLS based MPLS Layer 2 VPNs (L2VPN), MPLS Traffic Engineering, Service Provider Multicast, and Service Provider QoS.

Below you can see a sample video from the class, which covers IS-IS Route Leaking, and its implementation on IOS XR with the Routing Policy Language (RPL)

Sep
02

Edit: This topology has been deprecated and replaced by a similar but simpler topology used in INE's CCIE SPv3 Lab Workbook.  More information about this topology is available here.

Per the request of many candidates, I've finished putting the final touches on the hardware topology that will be used for our new CCIE SPv3.0 Advanced Technologies Class and Workbooks.  The topology consists of 20 routers - 2 of which are IOS XR 3.9.1,  6 of which are 7200VXRs, and 12 of which are 2600XMs - and 2 Catalyst ME3400 switches.

If you are interested in beta testing any of the content I'm working on for the upcoming CCIE SPv3 Advanced Technologies Class or CCIE SPv3 Workbook email me at bmcgahan@ine.com with the subject line CCIE SPv3 Beta. More details of the class, workbook, and rack rentals will be posted in the coming weeks.

The specific details of the topology are as follows:

Subscribe to INE Blog Updates